SuperZhang的网络笔记本。

yum 报错 except KeyboardInterrupt, e:

作者:superzhang 发布于:2015-9-4 5:11 分类:Python

之前有进行的操作是升级Python,从2.6升级到3.4版本。

于是出现报错:

[root@localhost code]# yum install readline-devel
  File "/usr/bin/yum", line 30
    except KeyboardInterrupt, e:
                            ^


解决方法如下:


vim /usr/bin/yum

#!/usr/bin/python  
import sys  
try:  
    import yum  


将上面的语句改为:

#!/usr/bin/python2.6  
import sys  
try:  
    import yum  
后面执行yum 就可以使用了

标签: Python 升级 except KeyboardInterrupt e: 报错

发表评论:

Powered by emlog